RTR logo

Colour Test Card Generator

Programming Software



Introduction

The Test Card Generator programming software has the normal features which make up the modern Windows™ interface: a title bar, a set of drop-down menus, an editing pane and a status bar. You can move its window wherever you like on your Windows™ desktop, but you cannot re-size or maximise it..

When run, the software initially loads a default image and a default set of teletext pages. You can configure these defaults using the Options menu selection.


The title bar

Title bar
The title bar contains the name of the application (TCGEN), the version number, a minimise button, a (disabled) maximise button and a close button. If an image and teletext pages have been loaded, their filenames are also displayed. If you right-click in the title bar you will get a context menu containing the Move, Minimize and Close items.

If you close the window (by clicking on the close button, selecting Close from the right-click menu or using the keyboard shortcut Alt-F4) you will be prompted to save the current teletext pages if any changes have been made.


The menu bar

Menu bar
The menu bar contains the drop-down menus File, Edit, View, Generator and Help. These menus may be activated by clicking on the appropriate menu name or by using a keyboard shortcut (hold down Alt and press the key corresponding to the underlined character). If any of the menu items are unavailable, they will be 'greyed out' and clicking on them will have no effect.


The status bar

Status bar
When a menu item is highlighted, the status bar displays a brief description of the function of that command. Otherwise, the status bar is split into three regions: a message region, a status region and an information region.

The message region

The message region displays "Please wait..." when the program is busy and will not respond to user input.

The status region

The status region displays the status of the current operation, if any:

The information region

When an image is displayed, the information region shows the Red, Green and Blue values of the pixel pointed at by the mouse. Note that the values use the Rec.601 coding range where 16 corresponds to black and 235 to peak white.

When a text page is displayed the information region shows the ASCII code of the character at the text cursor (caret) position.


File menu

File menu

The file menu is concerned with loading, saving and printing the test card (or other) image and the teletext pages. The file menu can be accessed by clicking on its name in the menu bar or by means of the keyboard short-cut Alt-F.

Load image

The Load image command loads the image you want to program into the Colour Test Card Generator. It will accept files in raw YUV format, in BMP (Windows bitmap) format, in JPEG (.JPG) format or in GIF format.

In the case of the BMP, JPEG and GIF formats the image is assumed to have square pixels, and will be scaled to fill the television frame (if the image shape isn't 4x3 it will be centred and cropped as necessary). In the case of the YUV format the image is assumed to correspond to the Rec.601 standard. If you are designing your own graphics specially for the Colour Test Card Generator it is probably best to create an image with dimensions 624 x 468. This will ensure that no horizontal scaling is required and therefore give the highest quality results.

The command calls up the Open File dialogue box:

Load dialogue

Image names shown with a web-browser icon are links to files on the internet. When selected they will be downloaded automatically; if you use a dial-up internet service you will be prompted to make a connection.

Load teletext

The Load teletext command loads the required teletext page or pages. It will accept either a file containing a single page (.VID) or a carousel file containing all four pages (.CAR). If a single page is loaded it replaces the page currently displayed; if a carousel file is loaded it replaces all four pages.

Save teletext

The Save teletext command saves the four teletext pages as a carousel file. The filename used is the same as that from which the pages were loaded (i.e. the contents of the file are replaced). If the pages were not loaded from a carousel file (i.e. they were typed in, imported via the clipboard or loaded individually), the Save command will display the Save As dialogue box so you can enter the desired filename. If the current teletext pages are unchanged, so don't need to be saved, the Save command is inhibited.

Save teletext as

The Save teletext as command saves the four teletext pages as a carousel file. You are prompted to select a file name; the .CAR extension will be automatically added. Use Save As rather than Save if you need to change the disk, directory (folder), or filename to something different from their current values.

Print Setup

The Print Setup command allows you to do the following: These affect subsequent uses of the Print image and Print teletext commands.

Print image

The Print image command prints out the current image. Best results will be obtained with a 'photo quality' colour printer.

Print teletext

The Print teletext command prints out the four teletext pages.

Exit

The Exit command quits from Test Card Generator and closes its window. If the current teletext pages in memory have not been saved, you are first prompted to save them.


Edit menu

Edit menu

The edit menu is concerned with editing the current teletext pages. The edit menu can be accessed by clicking on its name in the menu bar or by means of the keyboard short-cut Alt-E.

Cut

The Cut command transfers any selected text to the clipboard, and deletes it from the teletext page. If no text is selected, the Cut command is inhibited. Once the selected text is in the clipboard, you can Paste it either elsewhere in a teletext page or into any other application which supports pasting of text from the clipboard. Any previous contents of the clipboard are discarded.

Selected text is highlighted in reverse-video. You can select text in the following ways:

Once a block of text has been selected, you can alter the selection by holding down Shift and moving the cursor. If you want to change the start point of a selection, make the initial selection from right to left or from bottom to top. If you want to change the end point of a selection, make the initial selection from left to right or from top to bottom.

Copy

The Copy command transfers any selected text to the clipboard, but unlike Cut it leaves the teletext page unchanged. If no text is selected, the Copy command is inhibited. Once the selected text is in the clipboard, you can Paste it either elsewhere in a teletext page or into any other application which supports pasting of text from the clipboard. Any previous contents of the clipboard are discarded.

See Cut for details of how text may be selected.

Paste

The Paste command inserts the contents of the clipboard into the teletext page at the current position of the text cursor (caret). If the clipboard contains no text, the Paste command is inhibited. You can use Paste to transfer a block of text from elsewhere in a teletext page, or to insert a block of text which has been placed in the clipboard by any other application.

Note that the paste operation may cause some of the existing contents to be pushed off the right or bottom of the page. In this case they are lost.

Delete

The Delete command deletes any selected text, without copying it into the clipboard. See Cut for details of how text may be selected. The delete command has an identical effect to pressing the Delete key on the keyboard. Text which is deleted can only be recovered by reloading the teletext pages from a file.

Select All

The Select All command selects the entire teletext page. It is useful if you want to transfer the page into another application (e.g. a word processor) via the clipboard.

Text colours

The Text colours menu lists the possible text colours. Clicking on the menu item or pressing the specified function key selects the appropriate colour of text:

Text colours menu

Graphics colours

The Graphics colours menu lists the possible graphics colours. Clicking on the menu item or pressing the specified function key selects the appropriate colour of graphics:

Graphics colours menu

Special modes

The Special modes menu lists the special display modes. Clicking on the menu item or pressing the specified function key selects the appropriate mode:

Special modes menu

For details of these modes see the Teletext Codes section.


View menu

View menu

The View menu is used to select what is displayed: the test card image or one of the four teletext pages. It also controls special display modes useful when editing teletext pages.

The view menu can be accessed by clicking on its name in the menu bar or by means of the keyboard short-cut Alt-V.

Image

The Image command displays the current test card (or other) image.

Page 100

The Page 100 command displays the first teletext page (usually the index page). This page corresponds with the red fastext button on your TV remote control.

Page 200

The Page 200 command displays the second teletext page. This page corresponds with the green fastext button on your TV remote control.

Page 300

The Page 300 command displays the third teletext page. This page corresponds with the yellow fastext button on your TV remote control.

Page 400

The Page 400 command displays the fourth teletext page. This page corresponds with the blue fastext button on your TV remote control.

Show codes

The Show codes command alternates between the normal teletext page display and a mode in which the control codes are shown as two-letter mnemonics rather than being acted upon. The mnemonics are as follows:
NUNUL* DLDLE*
ARAlpha red GRGraphics red
AGAlpha green GGGraphics green
AYAlpha yellow GYGraphics yellow
ABAlpha blue GBGraphics blue
AMAlpha magenta GMGraphics magenta
ACAlpha cyan GCGraphics cyan
AWAlpha white CWGraphics white
FLFlash CDConceal display
STSteady CGContiguous graphics
EBEnd box SGSeparated graphics
SBStart box ECESC*
NHNormal height BBBlack background
DHDouble height NBNew background
SOSO* HGHold graphics
SISI* RGRelease graphics
*These control characters are reserved for compatibility with other data codes. They should not normally appear in a teletext page.

Reveal

The Reveal command alternates between concealing and revealing any parts of the page affected by a Conceal display control code.


Generator menu

Generator menu

The Generator menu is concerned with the programming of the hardware Colour Test Card Generator. It can be accessed by clicking on its name in the menu bar or by means of the keyboard short-cut Alt-G.

Check

The Check command tests the connection to the generator, including the PC's serial port, the cable and the generator itself.

Erase

The Erase command erases the current contents of the generator. This takes approximately thirty seconds.

Program

The Program command programs the current image, teletext pages etc. into the generator. It automatically performs the Check and Erase operations before starting the programming, which takes approximately six minutes.

If you have selected the 525-lines standard a message will be displayed reminding you that for operation in this mode an internal link must be changed. To do this disconnect the power supply from the generator and remove the four fixing screws (accessible from underneath). Carefully separate the top and bottom of the case, noting that they will still be joined by the power connections. For operation at 525 lines set link LK1 to the left position (as viewed with the connectors towards you, as per the illustration below); for operation at 180, 405, 441, 625 or 819 lines set link LK1 to the right position. Reassemble the case, taking extreme care not to trap or damage the power connections. Fit the fixing screws and reconnect the power supply.

Printed circuit board

Program from file

The Program from file command programs the generator from a ROM data file rather than from the currently loaded image and teletext pages. This allows the generator to be used for specialised purposes, such as to generate non-standard signals. Some suitable data files can be found on Peter Vince's web site.

Options

The Options command opens a dialogue box which allows you to set various options controlling what gets programmed into the generator, and to determine the default test card and teletext pages which are initially loaded.

Options dialogue

The various options are as follows:


Help menu

Help menu

The help menu gives access to the Colour Test Card Generator documentation, provides links to information via email or from the R.T.Russell website, and displays version information. The help menu can be accessed by clicking on its name in the menu bar or by means of the keyboard short-cut Alt-H.

Help Topics

The Help Topics command calls up the main help window, from which you can browse or search the online Colour Test Card Generator documentation.

Email

The Email command calls up your default mail program (if any) so that you can send a message to request help or information about the Colour Test Card Generator.

Website

The Website command calls up your default web browser (if any) and automatically directs it to the R.T.Russell home page.

About TCGEN

The About command displays the version number of the Test Card Generator programming software.


The editing pane

The editing pane is where the current test card image or a teletext page (if any) is displayed for viewing or (in the case of a teletext page only) for editing.

Keyboard commands

When a teletext page is displayed the following operations are available using the keyboard:

KeyOperation
Insert Toggle between insert and overtype mode. In overtype mode any character typed will over-write the existing character at that position on the line. In insert mode any character typed will 'push' the rest of the line to the right to make room. The insert/overtype status is indicated by the shape of the text cursor (caret): in overtype mode it is an underline and in insert mode it is a solid block.
Delete If any text is selected (highlighted) this key has an identical effect to the Delete command: the selected text is deleted, without being copied to the clipboard. Otherwise, the character to the immediate right of the cursor (caret) is deleted and the rest of the line is moved left to fill the gap.
Home Move the cursor (caret) to the start of the current line.
Ctrl/Home Move the cursor (caret) to the start of the top line.
End Move the cursor (caret) to the end of the current line.
Ctrl/End Move the cursor (caret) to the start of the bottom line.
Page Up Display the previous teletext page. If page 100 is displayed, Page Up has no effect.
Page Down Display the next teletext page. If page 400 is displayed, Page Down has no effect.
Left Move the cursor (caret) one character to the left, wrapping to the end of the previous line as required. If Shift is held down, select (or de-select) a character. If the cursor is already at the beginning of the page, the key has no effect.
Right Move the cursor (caret) one character to the right, wrapping to the beginning of the next line as required. If Shift is held down, select (or de-select) a character. If the cursor is already at the end of the page, the key has no effect.
Up Move the cursor (caret) up one line. If Shift is held down, select (or de-select) a line. If the cursor is already on the top line, the key has no effect.
Down Move the cursor (caret) down one line. If Shift is held down, select (or de-select) a line. If the cursor is already on the bottom line, the key has no effect.
Backspace Delete the character immediately to the left of the cursor (caret), and move the cursor left one position. The rest of the line, to the right of the cursor, is moved left to fill the gap. If the cursor is at the beginning of a line, concatenate the contents of the present line onto the end of the previous line.
Return (Enter) Insert a 'new line' at the current position of the cursor (caret). Everything to the right of the cursor will be moved onto the next line, and the rest of the page is moved down one line to make space (causing the bottom line to be lost). By this means you can split an existing line into two or more lines.
Esc This has the same effect as the Show codes menu option.
Tab This has the same effect as the Reveal menu option.

The 'printing' keys (letters, numbers and symbols) and function keys cause the appropriate character or control code to be entered at the position of the cursor (caret), and the cursor is then moved right by one position. If anything is selected (highlighted) when the key is pressed, it is first deleted. See the Teletext Codes section for the effects of control codes.

Mouse commands

When a teletext page is displayed the following operations are available using the mouse:

ActionOperation
Left click Clicking in the editing pane with the left mouse button causes the text cursor (caret) to be moved to the character position nearest to the mouse pointer. If Shift is held down, the region between the previous position of the text cursor and the new position will be selected.
Left drag Holding down the left mouse button and 'dragging' the mouse pointer over the program displayed in the editing pane causes a section of text to be selected. Dragging the mouse horizontally selects part or all of a line; dragging the mouse vertically selects a block of lines (only entire lines may be selected).
Right click Clicking in the editing pane with the right mouse button causes the Edit Menu to be displayed at that position.
Ctrl+left button Holding down the Ctrl key and pressing the left mouse button causes the graphics sixel at that position to be 'lit' (assuming that a graphics mode has been selected). By holding down the left button you can draw with the mouse.
Ctrl+right button Holding down the Ctrl key and pressing the right mouse button causes the graphics sixel at that position to be 'unlit' (assuming that a graphics mode has been selected). By holding down the right mouse button you can erase with the mouse.

Left CONTENTS

CONTINUE Right


Best viewed with Any Browser Valid HTML 3.2!
© Richard Russell 2005